spark-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sean Owen <sro...@gmail.com>
Subject Re: Unable to resolve dependency of sbt-mima-plugin since yesterday
Date Tue, 22 Oct 2019 19:18:41 GMT
Weird. Let's discuss at https://issues.apache.org/jira/browse/SPARK-29560

On Tue, Oct 22, 2019 at 2:06 PM Xingbo Jiang <jiangxb1987@gmail.com> wrote:
>
> Hi,
>
> Do you have any idea why the `./dev/lint-scala` check are failure with the following
message since yesterday ?
>
>> WARNING: An illegal reflective access operation has occurred
>> 9WARNING: Illegal reflective access by org.apache.ivy.util.url.IvyAuthenticator (file:/home/runner/work/spark/spark/build/sbt-launch-0.13.18.jar)
to field java.net.Authenticator.theAuthenticator
>> 10WARNING: Please consider reporting this to the maintainers of org.apache.ivy.util.url.IvyAuthenticator
>> 11WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective
access operations
>> 12WARNING: All illegal access operations will be denied in a future release
>> 13Scalastyle checks failed at following occurrences:
>> 14[error] (*:update) sbt.ResolveException: unresolved dependency: com.typesafe#sbt-mima-plugin;0.3.0:
not found
>> 15##[error]Process completed with exit code 1.
>
>
> I'm not able to reproduce the failure on my local environment, but seems all the open
PRs are failing on this check.
>
> Thanks,
>
> Xingbo

---------------------------------------------------------------------
To unsubscribe e-mail: dev-unsubscribe@spark.apache.org


Mime
View raw message