spark-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sean Owen <sro...@apache.org>
Subject Spark on JDK 14
Date Wed, 28 Oct 2020 20:44:26 GMT
For kicks, I tried Spark on JDK 14. 11 -> 14 doesn't change much, not as
much as 8 -> 9 (-> 11), and indeed, virtually all tests pass. For the
interested, these two seem to fail:

- ZooKeeperPersistenceEngine *** FAILED ***
  org.apache.zookeeper.KeeperException$ConnectionLossException:
KeeperErrorCode = ConnectionLoss for /spark/master_status

- parsing hour with various patterns *** FAILED ***
  java.time.format.DateTimeParseException: Text '2009-12-12 12 am' could
not be parsed: Invalid value for HourOfAmPm (valid values 0 - 11): 12

I'd expect that most applications would just work now on Spark 3 + Java 14.
I'd guess the same is true for Java 16 even, but, we're probably focused on
the LTS releases.

Kris Mok pointed out that Project Panama (in Java 17 maybe?) might have
implications as it changes off-heap memory access.

Mime
View raw message