spark-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sean Owen (JIRA)" <j...@apache.org>
Subject [jira] [Created] (SPARK-1387) Update build plugins, avoid plugin version warning, centralize versions
Date Tue, 01 Apr 2014 21:29:26 GMT
Sean Owen created SPARK-1387:
--------------------------------

             Summary: Update build plugins,  avoid plugin version warning, centralize versions
                 Key: SPARK-1387
                 URL: https://issues.apache.org/jira/browse/SPARK-1387
             Project: Spark
          Issue Type: Improvement
          Components: Build
    Affects Versions: 0.9.0
            Reporter: Sean Owen
            Priority: Minor


Another handful of small build changes to organize and standardize a bit, and avoid warnings:

- Update Maven plugin versions for good measure
- Since plugins need maven 3.0.4 already, require it explicitly (<3.0.4 had some bugs anyway)
- Use variables to define versions across dependencies where they should move in lock step
- ... and make this consistent between Maven/SBT




--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message