spark-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sean Owen (JIRA)" <>
Subject [jira] [Resolved] (SPARK-2799) Simplify some Scala operations for clarity, performance
Date Sat, 02 Aug 2014 19:48:11 GMT


Sean Owen resolved SPARK-2799.

    Resolution: Won't Fix

Too much risk of merge conflicts later -- not going to do this in a big-bang change.

> Simplify some Scala operations for clarity, performance
> -------------------------------------------------------
>                 Key: SPARK-2799
>                 URL:
>             Project: Spark
>          Issue Type: Improvement
>          Components: Examples, GraphX, Spark Core, Streaming
>    Affects Versions: 1.0.1
>            Reporter: Sean Owen
>            Priority: Minor
> For fun, here's a last minor suggestion for consideration before the 1.1 window closes.
> There are a number of instances where Scala operations can be simplified, for clarity
or even performance.
> For example getOrElse(null) can be orNull. filter(...).size can be faster as count(...).
An expression like "!...someLongChain...isEmpty" can be "... .nonEmpty". And so on.
> These are from code inspections. The PR will show the changes broken down by type in
separate commits. They should be quite safe.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message