spark-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Or (JIRA)" <j...@apache.org>
Subject [jira] [Created] (SPARK-5931) Use consistent naming for time properties
Date Fri, 20 Feb 2015 22:17:11 GMT
Andrew Or created SPARK-5931:
--------------------------------

             Summary: Use consistent naming for time properties
                 Key: SPARK-5931
                 URL: https://issues.apache.org/jira/browse/SPARK-5931
             Project: Spark
          Issue Type: Bug
          Components: Spark Core
    Affects Versions: 1.0.0
            Reporter: Andrew Or
            Assignee: Andrew Or


The naming of existing time configs is inconsistent. We currently have the following throughout
the code base:

spark.network.timeout (seconds)
spark.executor.heartbeatInterval (milliseconds)
spark.storage.blockManagerSlaveTimeoutMs (milliseconds)
spark.yarn.scheduler.heartbeat.interval-ms (milliseconds)

Instead, my proposal is to simplify the config name itself and make everything accept time
using the following format: 5s, 2ms, 100us. For instance:

spark.network.timeout = 5s
spark.executor.heartbeatInterval = 500ms
spark.storage.blockManagerSlaveTimeout = 100ms
spark.yarn.scheduler.heartbeatInterval = 400ms

We should do this soon before we keep introducing more time configs.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org


Mime
View raw message