spark-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jianshi Huang (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (SPARK-6155) Support latest Scala (2.11.6+)
Date Mon, 09 Mar 2015 05:32:38 GMT

     [ https://issues.apache.org/jira/browse/SPARK-6155?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jianshi Huang updated SPARK-6155:
---------------------------------
    Summary: Support latest Scala (2.11.6+)  (was: Support Scala 2.11.6+)

> Support latest Scala (2.11.6+)
> ------------------------------
>
>                 Key: SPARK-6155
>                 URL: https://issues.apache.org/jira/browse/SPARK-6155
>             Project: Spark
>          Issue Type: New Feature
>          Components: Build
>    Affects Versions: 1.3.0
>            Reporter: Jianshi Huang
>
> Just tried to build with Scala 2.11.5. failed with following error message:
> [INFO] Compiling 9 Scala sources to /Users/jianshuang/workspace/others/spark/repl/target/scala-2.11/classes...
> [ERROR] /Users/jianshuang/workspace/others/spark/repl/scala-2.11/src/main/scala/org/apache/spark/repl/SparkIMain.scala:1132:
value withIncompleteHandler is not a member of SparkIMain.this.global.PerRunReporting
> [ERROR]       currentRun.reporting.withIncompleteHandler((_, _) => isIncomplete =
true) {
> [ERROR]                            ^
> Looks like PerRunParsing has been changed from Reporting to Parsing in 2.11.5
> http://fossies.org/diffs/scala-sources/2.11.2_vs_2.11.5/src/compiler/scala/tools/nsc/Reporting.scala-diff.html
> Jianshi



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org


Mime
View raw message