spark-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "nirav patel (JIRA)" <j...@apache.org>
Subject [jira] [Created] (SPARK-9515) Creating JavaSparkContext throws NPE
Date Sat, 01 Aug 2015 01:00:06 GMT
nirav patel created SPARK-9515:
----------------------------------

             Summary: Creating JavaSparkContext throws NPE
                 Key: SPARK-9515
                 URL: https://issues.apache.org/jira/browse/SPARK-9515
             Project: Spark
          Issue Type: Bug
          Components: Java API
    Affects Versions: 1.3.1
            Reporter: nirav patel


I have spark application that runs agains YARN cluster. I run spark application as part of
my web application. I can't use spark-submit script. Way I run it is `java -cp myApp.jar com.myapp.Application`
which in turn initiate JavaSparkContext. It used to work with spark 1.0.2 and standalone cluster
but now with 1.3.1 and yarn its failing.

Caused by: java.lang.NullPointerException
	at org.apache.spark.deploy.yarn.ApplicationMaster$.sparkContextInitialized(ApplicationMaster.scala:580)
	at org.apache.spark.scheduler.cluster.YarnClusterScheduler.postStartHook(YarnClusterScheduler.scala:32)
	at org.apache.spark.SparkContext.<init>(SparkContext.scala:541)
	at org.apache.spark.api.java.JavaSparkContext.<init>(JavaSparkContext.scala:61)




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org


Mime
View raw message