spark-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sean Owen (JIRA)" <>
Subject [jira] [Commented] (SPARK-4816) Maven profile netlib-lgpl does not work
Date Mon, 14 Dec 2015 17:41:46 GMT


Sean Owen commented on SPARK-4816:

I tried your exact build above and I get lots of hits for netlib-native:

$ zipinfo -1 assembly/target/scala-2.10/spark-assembly-1.4.1-hadoop2.4.0.jar | grep netlib-native

Still not sure what to make of the difference here, though it seems to work here. You're saying
that at worst you think it's fixed for 1.4.2 by SPARK-9507. In that case I suppose it's already
resolved, just not in the 1.4.1 release. But as I say it does seem to work for me.

> Maven profile netlib-lgpl does not work
> ---------------------------------------
>                 Key: SPARK-4816
>                 URL:
>             Project: Spark
>          Issue Type: Bug
>          Components: Build
>    Affects Versions: 1.1.0
>         Environment: maven 3.0.5 / Ubuntu
>            Reporter: Guillaume Pitel
>            Priority: Minor
>             Fix For: 1.1.1
> When doing what the documentation recommends to recompile Spark with Netlib Native system
binding (i.e. to bind with openblas or, in my case, MKL), 
> mvn -Pnetlib-lgpl -Pyarn -Phadoop-2.3 -Dhadoop.version=2.3.0 -DskipTests clean package
> The resulting assembly jar still lacked the netlib-system class. (I checked the content
of spark-assembly...jar)
> When forcing the netlib-lgpl profile in MLLib package to be active, the jar is correctly
> So I guess it's a problem with the way maven passes profiles activitations to children
> Also, despite the documentation claiming that if the job's jar contains netlib with necessary
bindings, it should works, it does not. The classloader must be unhappy with two occurrences
of netlib ?

This message was sent by Atlassian JIRA

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message