spark-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ankit Raj Boudh (Jira)" <j...@apache.org>
Subject [jira] [Comment Edited] (SPARK-30308) Update Netty and Netty-all to address CVE-2019-16869
Date Fri, 20 Dec 2019 09:36:00 GMT

    [ https://issues.apache.org/jira/browse/SPARK-30308?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17000760#comment-17000760
] 

Ankit Raj Boudh edited comment on SPARK-30308 at 12/20/19 9:35 AM:
-------------------------------------------------------------------

[~srowen] , please help me to close this issue


was (Author: ankitraj):
@srowen , please help me to close this issue

> Update Netty and Netty-all to address CVE-2019-16869
> ----------------------------------------------------
>
>                 Key: SPARK-30308
>                 URL: https://issues.apache.org/jira/browse/SPARK-30308
>             Project: Spark
>          Issue Type: Dependency upgrade
>          Components: Security
>    Affects Versions: 2.4.4
>            Reporter: Vishwas
>            Priority: Minor
>              Labels: security
>             Fix For: 2.4.4
>
>
> As per [CVE-2019-16869|http://www.cvedetails.com/cve/CVE-2019-16869/], netty mishandled
whitespace before the colon in HTTP headers (such as a "Transfer-Encoding : chunked" line),
which lead to HTTP request smuggling.
> This issue has been resolved in version 4.1.42.Final for both netty and netty-all packages. 
>  
>  



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org


Mime
View raw message