spark-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chester <chesterxgc...@yahoo.com>
Subject Re: Running pi example error with spark 0.8.0 cdh4 version
Date Thu, 10 Oct 2013 11:26:09 GMT
I get the Same exception from the incubator-spark repository when i run spark-shell. I did
not investigate further, but went back to the meso/spark repo (last updated oct 4), and spark-shell
worked fine there.

Chester

Sent from my iPad

On Oct 9, 2013, at 11:44 PM, Shangyu Luo <lsyurd@gmail.com> wrote:

> Hello,
> I downloaded spark 0.8.0 cdh4 version, built and compiled it by using SPARK_HADOOP_VERSION=2.0.0-cdh4.4.0
sbt/sbt assembly. It was successfully built. But when I tried to run the pi example, I got
the error: Exception in thread "main" java.lang.NoClassDefFoundError: scala/ScalaObject
> I have set up SCALA_HOME and SPARK_HOME in bashrc and they worked well for spark 0.8.0
source version (I downloaded and compiled the source version before, but I have deleted it
now)
> So what's going wrong here? Any advice will be appreciated.
> Thanks! 
> 
> -- 
> --
> 
> Shangyu, Luo
> Department of Computer Science
> Rice University
> 

Mime
View raw message