Hello,

Shark doesn't have a matching version to the recent Spark 0.8.1 release yet.  If you want to run Shark, you'll need to stick with Spark 0.8.0 for the moment until Shark 0.8.1 is released.  I'd guess dropping back on that version would fix your problems.

Andrew


On Thu, Jan 9, 2014 at 1:23 PM, danoomistmatiste <kkhambadkone@yahoo.com> wrote:
Hi,  I have posted this query a couple of times but not received any
responses.

I have the following components installed and running for spark,

scala-2.9.3
spark-0.8.1-incubating-bin-cdh4

I am able to start the spark master (running on port 7077) and one worker.
I have also installed shark (shark-0.8.0-bin-cdh4).  I have set the
following in my shark-env.sh

export HADOOP_HOME=/Users/hadoop/hadoop-2.0.0-cdh4.2.0
export
HIVE_HOME=/Users/hadoop/shark-0.8.0-bin-cdh4/hive-0.9.0-shark-0.8.0-bin
export MASTER=spark://localhost:7077
export SPARK_HOME=/Users/hadoop/spark-0.8.1-incubating-bin-cdh4
export SPARK_MEM=1g
export SCALA_HOME=/Users/hadoop/scala-2.9.3

However, when I try to run the shark shell with ./shark-withinfo, I get the
following exception (buried within a lot of other info messages)

14/01/08 15:32:28 ERROR client.Client$ClientActor: Connection to master
failed; stopping client
14/01/08 15:32:28 ERROR cluster.SparkDeploySchedulerBackend: Disconnected
from Spark cluster!
14/01/08 15:32:28 ERROR cluster.ClusterScheduler: Exiting due to error from
cluster scheduler: Disconnected from Spark cluster

Anyone run into this issue before?



--
View this message in context: http://apache-spark-user-list.1001560.n3.nabble.com/PLEASE-HELP-shark-withinfo-not-connecting-to-spark-master-tp419.html
Sent from the Apache Spark User List mailing list archive at Nabble.com.