hey sandy, i think that pulreq is not relevant to the 0.9 branch i am using

switching to java 7 for sbt/sbt test made it work. not sure why...

On Sun, Mar 9, 2014 at 11:44 PM, Sandy Ryza <sandy.ryza@cloudera.com> wrote:
There was an issue related to this fixed recently:  https://github.com/apache/spark/pull/103

On Sun, Mar 9, 2014 at 8:40 PM, Koert Kuipers <koert@tresata.com> wrote:
edit last line of sbt/sbt, after which i run:
sbt/sbt test

On Sun, Mar 9, 2014 at 10:24 PM, Sean Owen <sowen@cloudera.com> wrote:

How are you specifying these args?

On Mar 9, 2014 8:55 PM, "Koert Kuipers" <koert@tresata.com> wrote:
i just checkout out the latest 0.9

no matter what java options i use in sbt/sbt (i tried -Xmx6G -XX:MaxPermSize=2000m -XX:ReservedCodeCacheSize=300m) i keep getting errors "java.lang.OutOfMemoryError: PermGen space" when running the tests.

curiously i managed to run the tests with the default dependencies, but with cdh4.5.0 mr1 dependencies i always hit the dreaded Permgen space issue.

Any suggestions?