spark-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ian Ferreira <ianferre...@hotmail.com>
Subject Re: Can't be built on MAC
Date Thu, 01 May 2014 19:35:27 GMT
HI Zhige,
I had the same issue and revert to using JDK 1.7.055

From:  Zhige Xin <xinzhige8@gmail.com>
Reply-To:  <user@spark.apache.org>
Date:  Thursday, May 1, 2014 at 12:32 PM
To:  <user@spark.apache.org>
Subject:  Can't be built on MAC

Hi dear all,

When I tried to build Spark 0.9.1 on my Mac OS X 10.9.2 with Java 8, I found
the following errors:

[error] error while loading CharSequence, class file
'/Library/Java/JavaVirtualMachines/jdk1.8.0_05.jdk/Contents/Home/jre/lib/rt.
jar(java/lang/CharSequence.class)' is broken
[error] (bad constant pool tag 18 at byte 10)
[error] error while loading Comparator, class file
'/Library/Java/JavaVirtualMachines/jdk1.8.0_05.jdk/Contents/Home/jre/lib/rt.
jar(java/util/Comparator.class)' is broken
[error] (bad constant pool tag 18 at byte 20)
[error] two errors found
[debug] Compilation failed (CompilerInterface)
[error] (compile:compile) Compilation failed

Can someone tell me what is going on? Thanks a lot!



Best,
Isaiah



Mime
View raw message