spark-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mayur Rustagi <mayur.rust...@gmail.com>
Subject Re: Error while launching ec2 spark cluster with HVM (r3.large)
Date Fri, 23 May 2014 08:20:35 GMT
I am not sure if EC2 script was updated for R3, R3 doesnt provide formatted
instance store also requires newer version of AMI for the same.

Regards
Mayur

Mayur Rustagi
Ph: +1 (760) 203 3257
http://www.sigmoidanalytics.com
@mayur_rustagi <https://twitter.com/mayur_rustagi>



On Fri, May 23, 2014 at 4:32 AM, Xiangrui Meng <mengxr@gmail.com> wrote:

> Was the error message the same as you posted when you used `root` as
> the user id? Could you try this:
>
> 1) Do not specify user id. (Default would be `root`.)
> 2) If it fails in the middle, try `spark-ec2 .... --resume launch
> <cluster>` to continue launching the cluster.
>
> Best,
> Xiangrui
>
> On Thu, May 22, 2014 at 12:44 PM, adparker <adparker@gmail.com> wrote:
> > I had this problem too and fixed it by setting the wait time-out to a
> larger
> > value: --wait
> >
> > For example, in "stand alone" mode with default values, a time out of 480
> > seconds worked for me:
> >
> > $ cd spark-0.9.1/ec2
> > $ ./spark-ec2 --key-pair=XXXX --identity-file=XXXX
> --instance-type=r3.large
> > --wait=480  launch XXXX
> >
> >
> >
> >
> > --
> > View this message in context:
> http://apache-spark-user-list.1001560.n3.nabble.com/Error-while-launching-ec2-spark-cluster-with-HVM-r3-large-tp5862p6276.html
> > Sent from the Apache Spark User List mailing list archive at Nabble.com.
>

Mime
View raw message