spark-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From shlee0605 <>
Subject Spark SQL standalone application compile error
Date Tue, 10 Jun 2014 04:25:52 GMT
I am having some trouble with compiling Spark standalone application that
uses new Spark SQL feature.
I have used the exact same code from "RDDRelation.scala" that is included in
Spark's examples.

I set my build.sbt file like as follows:

name := "spark-sql"

version := "1.0"

scalaVersion := "2.10.4"

libraryDependencies += "org.apache.spark" %% "spark-core" % "1.0.0"

resolvers += "Akka Repository" at ""

When I try to compile, I get the following error:

object sql is not a member of package org.apache.spark
[error] import org.apache.spark.sql.SQLContext
[error]                         ^
not found: type SQLContext
[error]     val sqlContext = new SQLContext(sc)
[error]                          ^

By the way, when I ran the same code line by line from the spark-shell, it
worked well.
How can I fix this? 

Seunghyun Lee

View this message in context:
Sent from the Apache Spark User List mailing list archive at

View raw message