spark-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sean Owen <so...@cloudera.com>
Subject Re: HBase 0.96+ with Spark 1.0+
Date Sat, 28 Jun 2014 11:22:47 GMT
This sounds like an instance of roughly the same item as in
https://issues.apache.org/jira/browse/SPARK-1949  Have a look at
adding that exclude to see if it works.

On Fri, Jun 27, 2014 at 10:21 PM, Stephen Boesch <javadba@gmail.com> wrote:
> The present trunk is built and tested against HBase 0.94.
>
>
> I have tried various combinations of versions of HBase 0.96+ and Spark 1.0+
> and all end up with
>
> 14/06/27 20:11:15 INFO HttpServer: Starting HTTP Server
> [error] (run-main-0) java.lang.SecurityException: class
> "javax.servlet.FilterRegistration"'s signer information does not match
> signer information of other classes in the same package
> java.lang.SecurityException: class "javax.servlet.FilterRegistration"'s
> signer information does not match signer information of other classes in the
> same package
>         at java.lang.ClassLoader.checkCerts(ClassLoader.java:952)
>
>
> I have tried a number of different ways to exclude javax.servlet related
> jars. But none have avoided this error.
>
> Anyone have a (small-ish) build.sbt that works with later versions of HBase?
>
>

Mime
View raw message