spark-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jianshi Huang <jianshi.hu...@gmail.com>
Subject Re: Spray client reports Exception: akka.actor.ActorSystem.dispatcher()Lscala/concurrent/ExecutionContext
Date Tue, 28 Oct 2014 18:04:25 GMT
Here's the answer I got from Akka's user ML.

"""
This looks like a binary incompatibility issue. As far as I know Spark is
using a custom built Akka and Scala for various reasons.

You should ask this on the Spark mailing list, Akka is binary compatible
between major versions (2.3.6 is compatible with 2.3.4) but Spark uses its
own build which I guess does not guarantee binary compatiblity.
"""

*Anyone have used Spray or other Akka dependent libraries? Any binary
compatibility issues?*

Does that mean if I build Spray with Spark's Akka version

      <akka.group>org.spark-project.akka</akka.group>
      <akka.version>2.3.4-spark</akka.version>

it should solve problem. Makes sense? I'll give it a shot when I have time,
now probably I'll just not using Spray client...

Cheers,
Jianshi



On Tue, Oct 28, 2014 at 6:02 PM, Jianshi Huang <jianshi.huang@gmail.com>
wrote:

> Hi,
>
> I got the following exceptions when using Spray client to write to
> OpenTSDB using its REST API.
>
>   Exception in thread "pool-10-thread-2" java.lang.NoSuchMethodError:
> akka.actor.ActorSystem.dispatcher()Lscala/concurrent/ExecutionContext;
>
> It worked locally in my Intellij but failed when I launch it from
> Spark-submit.
>
> Google suggested it's a compatibility issue in Akka. And I'm using latest
> Spark built from the HEAD, so the Akka used in Spark-submit is 2.3.4-spark.
>
> I tried both Spray 1.3.2 (built for Akka 2.3.6) and 1.3.1 (built for
> 2.3.4). Both failed with the same exception.
>
> Anyone has idea what went wrong? Need help!
>
> --
> Jianshi Huang
>
> LinkedIn: jianshi
> Twitter: @jshuang
> Github & Blog: http://huangjs.github.com/
>



-- 
Jianshi Huang

LinkedIn: jianshi
Twitter: @jshuang
Github & Blog: http://huangjs.github.com/

Mime
View raw message