spark-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Lewis <lordjoe2...@gmail.com>
Subject Re: com.esotericsoftware.kryo.KryoException: Encountered unregistered class ID: 13994
Date Wed, 29 Oct 2014 03:36:17 GMT
I wrote a custom class loader to find all classes that were loaded that
implement Serializabke. I ran it locally to load all classes and registered
ALL of these - I still get these issues

On Tue, Oct 28, 2014 at 8:02 PM, Ganelin, Ilya <Ilya.Ganelin@capitalone.com>
wrote:

>  Have you checked for any global variables in your scope? Remember that
> even if variables are not passed to the function they will be included as
> part of the context passed to the nodes. If you can't zen out what is
> breaking then try to simplify what you're doing. Set up a simple test call
> (like a map) with the same objects you're trying to serialize and see if
> those work.
>
>
> -----Original Message-----
> *From: *Steve Lewis [lordjoe2000@gmail.com]
> *Sent: *Tuesday, October 28, 2014 10:46 PM Eastern Standard Time
> *To: *user@spark.apache.org
> *Subject: *com.esotericsoftware.kryo.KryoException: Encountered
> unregistered class ID: 13994
>
>   A cluster I am running on keeps getting KryoException. Unlike the Java
> serializer the Kryo Exception gives no clue as to what class is giving the
> error
> The application runs properly locally but no the cluster and I have my own
> custom KryoRegistrator and register sereral dozen classes - essentially
> everything I can find which implements Serializable
> How to I find what the KryoSerializer issue is?
> I would love to see a list of all classes Kryo serialized
>
>

-

Mime
View raw message