Run this way:

bin/spark-submit --class org.apache.spark.examples.streaming.TwitterPopularTags lib/spark-examples-1.1.0-hadoop1.0.4.jar

Or this way:

 bin/run-example org.apache.spark.examples.streaming.TwitterPopularTags


Thanks
Best Regards

On Thu, Nov 13, 2014 at 5:02 PM, <jishnu.prathap@wipro.com> wrote:

Hi

                I am getting the following error while running the TwitterPopularTags  example .I am using spark-1.1.0-bin-hadoop2.4 .

jishnu@getafix:~/spark/bin$ run-example TwitterPopularTags *** ** ** *** **

 

spark assembly has been built with Hive, including Datanucleus jars on classpath

java.lang.ClassNotFoundException: org.apache.spark.examples.org.apache.spark.streaming.examples.TwitterPopularTags

        at java.net.URLClassLoader$1.run(URLClassLoader.java:366)

        at java.net.URLClassLoader$1.run(URLClassLoader.java:355)

        at java.security.AccessController.doPrivileged(Native Method)

        at java.net.URLClassLoader.findClass(URLClassLoader.java:354)

        at java.lang.ClassLoader.loadClass(ClassLoader.java:425)

        at java.lang.ClassLoader.loadClass(ClassLoader.java:358)

        at java.lang.Class.forName0(Native Method)

        at java.lang.Class.forName(Class.java:270)

        at org.apache.spark.deploy.SparkSubmit$.launch(SparkSubmit.scala:318)

        at org.apache.spark.deploy.SparkSubmit$.main(SparkSubmit.scala:75)

        at org.apache.spark.deploy.SparkSubmit.main(SparkSubmit.scala)

 

tried executing in three  different machines but all showed the same error.I am able to run other examples like SparkPi .  

 

 

Thanks & Regards

Jishnu Menath Prathap

BAS EBI(Open Source)

 

 

The information contained in this electronic message and any attachments to this message are intended for the exclusive use of the addressee(s) and may contain proprietary, confidential or privileged information. If you are not the intended recipient, you should not disseminate, distribute or copy this e-mail. Please notify the sender immediately and destroy all copies of this message and any attachments.

WARNING: Computer viruses can be transmitted via email. The recipient should check this email and any attachments for the presence of viruses. The company accepts no liability for any damage caused by any virus transmitted by this email.

www.wipro.com