spark-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marcelo Vanzin <van...@cloudera.com>
Subject Re: correct/best way to install custom spark1.2 on cdh5.3.0?
Date Thu, 08 Jan 2015 23:43:08 GMT
On Thu, Jan 8, 2015 at 3:33 PM, freedafeng <freedafeng@yahoo.com> wrote:
> I installed the custom as a standalone mode as normal. The master and slaves
> started successfully.
> However, I got error when I ran a job. It seems to me from the error message
> the some library was compiled against hadoop1, but my spark was compiled
> against hadoop2.

Is that using your build or the CDH build?

It seems you have the wrong HBase dependency. I'd be surprised if the
CDH build had that problem, since IIRC we don't even build HBase for
hadoop 1 anymore.

Take a look at examples/pom.xml in Spark for an example, which has
different profiles for dealing with the HBase builds for hadoop1 and
hadoop2.

-- 
Marcelo

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@spark.apache.org
For additional commands, e-mail: user-help@spark.apache.org


Mime
View raw message