spark-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Håkan Jonsson <haj...@gmail.com>
Subject Re: No AMI for Spark 1.2 using ec2 scripts
Date Mon, 26 Jan 2015 12:26:01 GMT
Thanks. Turns out this is a proxy problem somehow. Sorry to bother you.

/Håkan

On Mon Jan 26 2015 at 11:02:18 AM Franc Carter <franc.carter@rozettatech.com>
wrote:

>
> AMI's are specific to an AWS region, so the ami-id of the spark AMI in
> us-west will be different if it exists. I can't remember where but I have a
> memory of seeing somewhere that the AMI was only in us-east
>
> cheers
>
> On Mon, Jan 26, 2015 at 8:47 PM, Håkan Jonsson <hajons@gmail.com> wrote:
>
>> Thanks,
>>
>> I also use Spark 1.2 with prebuilt for Hadoop 2.4. I launch both 1.1 and
>> 1.2 with the same command:
>>
>> ./spark-ec2 -k foo -i bar.pem launch mycluster
>>
>> By default this launches in us-east-1. I tried changing the the region
>> using:
>>
>> -r us-west-1 but that had the same result:
>>
>> Could not resolve AMI at:
>> https://raw.github.com/mesos/spark-ec2/v4/ami-list/us-west-1/pvm
>>
>> Looking up
>> https://raw.github.com/mesos/spark-ec2/v4/ami-list/us-west-1/pvm in a
>> browser results in the same AMI ID as yours. If I search for ami-7a320f3f
>> AMI in AWS, I can't find any such image. I tried searching in all regions I
>> could find in the AWS console.
>>
>> The AMI for 1.1 is spark.ami.pvm.v9 (ami-5bb18832). I can find that AMI
>> in us-west-1.
>>
>> Strange. Not sure what to do.
>>
>> /Håkan
>>
>>
>> On Mon Jan 26 2015 at 9:02:42 AM Charles Feduke <charles.feduke@gmail.com>
>> wrote:
>>
>> I definitely have Spark 1.2 running within EC2 using the spark-ec2
>> scripts. I downloaded Spark 1.2 with prebuilt for Hadoop 2.4 and later.
>>
>> What parameters are you using when you execute spark-ec2?
>>
>>
>> I am launching in the us-west-1 region (ami-7a320f3f) which may explain
>> things.
>>
>> On Mon Jan 26 2015 at 2:40:01 AM hajons <hajons@gmail.com> wrote:
>>
>> Hi,
>>
>> When I try to launch a standalone cluster on EC2 using the scripts in the
>> ec2 directory for Spark 1.2, I get the following error:
>>
>> Could not resolve AMI at:
>> https://raw.github.com/mesos/spark-ec2/v4/ami-list/us-east-1/pvm
>>
>> It seems there is not yet any AMI available on EC2. Any ideas when there
>> will be one?
>>
>> This works without problems for version 1.1. Starting up a cluster using
>> these scripts is so simple and straightforward, so I am really missing it
>> on
>> 1.2.
>>
>> /Håkan
>>
>>
>>
>>
>>
>> --
>> View this message in context:
>> http://apache-spark-user-list.1001560.n3.nabble.com/No-AMI-for-Spark-1-2-using-ec2-scripts-tp21362.html
>> Sent from the Apache Spark User List mailing list archive at Nabble.com.
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: user-unsubscribe@spark.apache.org
>> For additional commands, e-mail: user-help@spark.apache.org
>>
>
>
>
> --
>
> *Franc Carter* | Systems Architect | Rozetta Technology
>
> franc.carter@rozettatech.com  <franc.carter@rozettatech.com>|
> www.rozettatechnology.com
>
> Tel: +61 2 8355 2515
>
> Level 4, 55 Harrington St, The Rocks NSW 2000
>
> PO Box H58, Australia Square, Sydney NSW 1215
>
> AUSTRALIA
>
>

Mime
View raw message