spark-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aniket Bhatnagar <aniket.bhatna...@gmail.com>
Subject Re: spark-network-yarn 2.11 depends on spark-network-shuffle 2.10
Date Thu, 08 Jan 2015 10:16:48 GMT
Actually it does causes builds with SBT 0.13.7 to fail with the error
"Conflicting cross-version suffixes". I have raised a defect SPARK-5143 for
this.

On Wed Jan 07 2015 at 23:44:21 Marcelo Vanzin <vanzin@cloudera.com> wrote:

> This particular case shouldn't cause problems since both of those
> libraries are java-only (the scala version appended there is just for
> helping the build scripts).
>
> But it does look weird, so it would be nice to fix it.
>
> On Wed, Jan 7, 2015 at 12:25 AM, Aniket Bhatnagar
> <aniket.bhatnagar@gmail.com> wrote:
> > It seems that spark-network-yarn compiled for scala 2.11 depends on
> > spark-network-shuffle compiled for scala 2.10. This causes cross version
> > dependencies conflicts in sbt. Seems like a publishing error?
> >
> > http://www.uploady.com/#!/download/6Yn95UZA0DR/3taAJFjCJjrsSXOR
>
>
>
> --
> Marcelo
>

Mime
View raw message