spark-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Josh Rosen <rosenvi...@gmail.com>
Subject Re: Number of cores is 0 in WebUI when use bin/spark-submit
Date Sun, 04 Jan 2015 21:18:52 GMT
I believe that this is showing the number of cores currently assigned to the application, so
a completed application will show zero cores.  I’ve filed https://issues.apache.org/jira/browse/SPARK-5076 to
remove these columns for completed applications. 

On December 29, 2014 at 6:56:13 PM, Wei Da (xwd0520@qq.com) wrote:

Hi all,

I’m trying to use bin/spark-submit in Spark 1.1.0 to run my applications. The applications
finished successfully, but I saw the column for “Cores” is always 0. 

I have tried the following two scripts, but got the same result. 
./spark-submit --master spark://masterIP:7077 --class SparkPi ~/app/sparktest.jar 10

./spark-submit --master spark://masterIP:7077 --total-executor-cores 16 --class SparkPi ~/app/sparktest.jar
10

Following is what I see in the WebUI. Does anyone know the reasons? Thanks a lot!




Wei Da
xwd0520@qq.com




Mime
View raw message