spark-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mjhb <sp...@mjhb.com>
Subject Build fails on 1.3 Branch
Date Sun, 29 Mar 2015 15:48:50 GMT
I tried pulling the source and building for the first time, but cannot get
past the "object NoRelation is not a member of package
org.apache.spark.sql.catalyst.plans.logical" error below on the 1.3 branch. 
I can build the 1.2 branch.

I have tried with both -Dscala-2.11 and 2.10 (after running the appropriate
change-version-to-2.1#.sh), and with different combinations of hadoop flags.

Relevant excerpts below - full build output available at
http://mjhb.com/tmp/build-spark-1.3.out or
http://mjhb.com/tmp/build-spark-1.3.out.gz 

$ git branch
* branch-1.3
$ build/mvn -e -X -DskipTests clean package
Apache Maven 3.0.5
Maven home: /usr/share/maven
Java version: 1.7.0_76, vendor: Oracle Corporation
Java home: /usr/lib/jvm/java-7-oracle/jre
Default locale: en_US, platform encoding: UTF-8
OS name: "linux", version: "3.16.0-33-generic", arch: "amd64", family:
"unix"

<snipped...>

[error]
/home/marty/work/spark-1.3-maint/sql/core/src/test/scala/org/apache/spark/sql/ColumnExpressionSuite.scala:21:
object NoRelation is not a member of package
org.apache.spark.sql.catalyst.plans.logical
[error] import org.apache.spark.sql.catalyst.plans.logical.{Project,
NoRelation}
[error]        ^
[error] one error found
[debug] Compilation failed (CompilerInterface)
[error] Compile failed at Mar 29, 2015 7:52:54 AM [5.793s]




--
View this message in context: http://apache-spark-user-list.1001560.n3.nabble.com/Build-fails-on-1-3-Branch-tp22275.html
Sent from the Apache Spark User List mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@spark.apache.org
For additional commands, e-mail: user-help@spark.apache.org


Mime
View raw message