Marcelo,

Thanks.  The one in the CDH repo fixed it :)

On Wed, Mar 4, 2015 at 4:37 PM, Marcelo Vanzin <vanzin@cloudera.com> wrote:
Hi Kevin,

If you're using CDH, I'd recommend using the CDH repo [1], and also
the CDH version when building your app.

[1] http://www.cloudera.com/content/cloudera/en/documentation/core/v5-2-x/topics/cdh_vd_cdh5_maven_repo.html

On Wed, Mar 4, 2015 at 4:34 PM, Kevin Peng <kpeng1@gmail.com> wrote:
> Ted,
>
> I am currently using CDH 5.3 distro, which has Spark 1.2.0, so I am not too
> sure about the compatibility issues between 1.2.0 and 1.2.1, that is why I
> would want to stick to 1.2.0.
>
>
>
> On Wed, Mar 4, 2015 at 4:25 PM, Ted Yu <yuzhihong@gmail.com> wrote:
>>
>> Kevin:
>> You can try with 1.2.1
>>
>> See this thread: http://search-hadoop.com/m/JW1q5Vfe6X1
>>
>> Cheers
>>
>> On Wed, Mar 4, 2015 at 4:18 PM, Kevin Peng <kpeng1@gmail.com> wrote:
>>>
>>> Marcelo,
>>>
>>> Yes that is correct, I am going through a mirror, but 1.1.0 works
>>> properly, while 1.2.0 does not.  I suspect there is crc in the 1.2.0 pom
>>> file.
>>>
>>> On Wed, Mar 4, 2015 at 4:10 PM, Marcelo Vanzin <vanzin@cloudera.com>
>>> wrote:
>>>>
>>>> Seems like someone set up "m2.mines.com" as a mirror in your pom file
>>>> or ~/.m2/settings.xml, and it doesn't mirror Spark 1.2 (or does but is
>>>> in a messed up state).
>>>>
>>>> On Wed, Mar 4, 2015 at 3:49 PM, kpeng1 <kpeng1@gmail.com> wrote:
>>>> > Hi All,
>>>> >
>>>> > I am currently having problem with the maven dependencies for version
>>>> > 1.2.0
>>>> > of spark-core and spark-hive.  Here are my dependencies:
>>>> >     <dependency>
>>>> >       <groupId>org.apache.spark</groupId>
>>>> >       <artifactId>spark-core_2.10</artifactId>
>>>> >       <version>1.2.0</version>
>>>> >     </dependency>
>>>> >     <dependency>
>>>> >       <groupId>org.apache.spark</groupId>
>>>> >       <artifactId>spark-hive_2.10</artifactId>
>>>> >       <version>1.2.0</version>
>>>> >     </dependency>
>>>> >
>>>> > When the dependencies are set to version 1.1.0, I do not get any
>>>> > errors.
>>>> > Here are the errors I am getting from artifactory for version 1.2.0 of
>>>> > spark-core:
>>>> > error=Could not transfer artifact
>>>> > org.apache.spark\:spark-core_2.10\:pom\:1.2.0 from/to repo
>>>> > (https\://m2.mines.com\:8443/artifactory/repo)\: Failed to transfer
>>>> > file\:
>>>> >
>>>> > https\://m2.mines.com\:8443/artifactory/repo/org/apache/spark/spark-core_2.10/1.2.0/spark-core_2.10-1.2.0.pom.
>>>> > Return code is\: 409 , ReasonPhrase\:Conflict.
>>>> >
>>>> > The error is the same for spark-hive.
>>>> >
>>>> >
>>>> >
>>>> >
>>>> > --
>>>> > View this message in context:
>>>> > http://apache-spark-user-list.1001560.n3.nabble.com/Issues-with-maven-dependencies-for-version-1-2-0-but-not-version-1-1-0-tp21919.html
>>>> > Sent from the Apache Spark User List mailing list archive at
>>>> > Nabble.com.
>>>> >
>>>> > ---------------------------------------------------------------------
>>>> > To unsubscribe, e-mail: user-unsubscribe@spark.apache.org
>>>> > For additional commands, e-mail: user-help@spark.apache.org
>>>> >
>>>>
>>>>
>>>>
>>>> --
>>>> Marcelo
>>>
>>>
>>
>



--
Marcelo