spark-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Yu <yuzhih...@gmail.com>
Subject Re: required: org.apache.spark.streaming.dstream.DStream[org.apache.spark.mllib.linalg.Vector]
Date Sun, 28 Jun 2015 14:53:26 GMT
Can you show us your code around line 100 ?

Which Spark release are you compiling against ?

Cheers

On Sun, Jun 28, 2015 at 5:49 AM, Arthur Chan <arthur.hk.chan@gmail.com>
wrote:

> Hi,
>
> I am trying Spark with some sample programs,
>
>
> In my code, the following items are imported:
>
> import
> org.apache.spark.mllib.regression.{StreamingLinearRegressionWithSGD,
> LabeledPoint}
>
> import org.apache.spark.mllib.regression.{StreamingLinearRegressionWithSGD}
>
> import org.apache.spark.streaming.{Seconds, StreamingContext}
>
> import scala.util.Random
>
> I got following error:
>
> [error] StreamingModel.scala:100: type mismatch;
>
> [error]  found   :
> org.apache.spark.streaming.dstream.DStream[org.apache.spark.mllib.regression.LabeledPoint]
>
> [error]  required:
> org.apache.spark.streaming.dstream.DStream[org.apache.spark.mllib.linalg.Vector]
>
> [error]     model.predictOn(labeledStream).print()
>
> [error]                     ^
>
> [error] one error found
>
> [error] (compile:compile) Compilation failed
>
>
> Any idea?
>
>
> Regards
>

Mime
View raw message