spark-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevin Jung <>
Subject Re: Can't find directory after resetting REPL state
Date Mon, 17 Aug 2015 00:31:45 GMT
Thanks Ted, it may be a bug. This is a jira ticket. 


------- Original Message -------
Sender : Ted Yu<>
Date : 2015-08-16 11:29 (GMT+09:00)
Title : Re: Can't find directory after resetting REPL state

I tried with master branch and got the following:


On Sat, Aug 15, 2015 at 1:03 AM, Kevin Jung <> wrote:

Spark shell can't find base directory of class server after running ":reset" command.
scala> :reset
scala> 1
uncaught exception during compilation: java.lang.AssertiON-ERROR
java.lang.AssertiON-ERROR: assertion failed: Tried to find '$line33' in '/tmp/spark-f47f3917-ac31-4138-bf1a-a8cefd094ac3'
but it is not a directory
~~~impossible to command anymore~~~
I figure out reset() method in SparkIMain try to delete virtualDirectory and then create again.
But virtualDirectory.create() makes a file, not a directory.
Does anyone face a same problem under spark 1.4.0?


상기 메일은 지정된 수신인만을 위한 것이며, 부정경쟁방지 및 영업비밀보호에
관한 법률,개인정보 보호법을 포함하여
 관련 법령에 따라 보호의 대상이 되는 영업비밀, 산업기술,기밀정보,
개인정보 등을 포함하고 있을 수 있습니다.
본 문서에 포함된 정보의 전부 또는 일부를 무단으로 복사 또는 사용하거나
제3자에게 공개, 배포, 제공하는 것은 엄격히
 금지됩니다. 본 메일이 잘못 전송된 경우 발신인 또는 당사에게 알려주시고
본 메일을 즉시 삭제하여 주시기 바랍니다. 
The contents of this e-mail message and any attachments are confidential and are intended
solely for addressee.
 The information may also be legally privileged. This transmission is sent in trust, for the
sole purpose of delivery
 to the intended recipient. If you have received this transmission in error, any use, reproduction
or dissemination of
 this transmission is strictly prohibited. If you are not the intended recipient, please immediately
notify the sender
 by reply e-mail or phone and delete this message and its attachments, if any.
  • Unnamed multipart/related (inline, None, 0 bytes)
View raw message