Has anyone experienced issues running Spark 1.4.1 on a Mac OSX Yosemite?

I'm been running a standalone 1.3.1 fine but it failed when trying to run 1.4.1. (I also trie 1.4.0).

I've tried both the pre-built packages as well as compiling from source, both with the same results (I can successfully compile with both mvn and sbt (after fixing the sbt.jar - which was corrupt)
After downloading/building spark and running ./bin/pyspark or ./bin/spark-shell it silently exits with a code 1.
Creating a context in python I get: Exception: Java gateway process exited before sending the driver its port number

I couldn't find any specific resolutions on the web.
I did add 'pyspark-shell' to the PYSPARK_SUBMIT_ARGS but to no effect.

Anyone have any further ideas I can explore?
Cheers
   -Alun.