spark-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Yu <yuzhih...@gmail.com>
Subject Re: Required file not found: sbt-interface.jar
Date Mon, 02 Nov 2015 13:53:27 GMT
sbt-interface.jar is under build/zinc-0.3.5.3/lib/sbt-interface.jar

You can run build/mvn first to download it.

Cheers

On Mon, Nov 2, 2015 at 1:51 AM, Todd <bit1129@163.com> wrote:

> Hi,
> I am trying to build spark 1.5.1 in my environment, but encounter the
> following error complaining Required file not found: sbt-interface.jar:
> The error message is below and I am building with:
>
> ./make-distribution.sh --name spark-1.5.1-bin-2.6.0 --tgz --with-tachyon
> -Phadoop-2.6 -Dhadoop.version=2.6.0 -Pyarn -Phive -Dhive-version=1.2.1
> -Phive-thriftserver -Pspark-ganglia-lgpl -Dscala-2.10.4
>
>
>
> [INFO] --- scala-maven-plugin:3.2.2:compile (scala-compile-first) @
> spark-launcher_2.10 ---
> [INFO] Using zinc server for incremental compilation
> [error] Required file not found: sbt-interface.jar
> [error] See zinc -help for information about locating necessary files
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Reactor Summary:
> [INFO]
> [INFO] Spark Project Parent POM ........................... SUCCESS [
> 3.192 s]
> [INFO] Spark Project Launcher ............................. FAILURE [
> 2.950 s]
>
>

Mime
View raw message