Maybe you were trying to embed pictures for the error and your code - but they didn't go through.

On Mon, May 2, 2016 at 10:32 AM, meson10 <spark@piyushverma.net> wrote:
Hi,

I am trying to save a RDD to Cassandra but I am running into the following
error:



The Python code looks like this:


I am using DSE 4.8.6 which runs Spark 1.4.2

I ran through a bunch of existing posts on this mailing lists and have
already performed the following routines:

 * Ensure that there is no redundant cassandra .jar lying around,
interfering with the process.
 * Wiped clean and reinstall DSE to ensure that.
 * Tried Loading data from Cassandra to ensure that Spark <-> Cassandra
communication is working. I used        print
self.context.cassandraTable(keyspace='test', table='dummy').collect() to
validate that.
 * Ensure there are no null values in my dataset that is being written.
 * The namespace and the table exist in Cassandra using cassandra@cqlsh>
SELECT * from test.dummy ;



--
View this message in context: http://apache-spark-user-list.1001560.n3.nabble.com/java-lang-NullPointerException-while-performing-rdd-SaveToCassandra-tp26862.html
Sent from the Apache Spark User List mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@spark.apache.org
For additional commands, e-mail: user-help@spark.apache.org