spark-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sean Owen <so...@cloudera.com>
Subject Re: Spark 2.0 error: Wrong FS: file://spark-warehouse, expected: file:///
Date Tue, 02 Aug 2016 23:48:59 GMT
This is https://issues.apache.org/jira/browse/SPARK-15899  -- anyone
seeing this please review the proposed change. I think it's stalled
and needs an update.

On Tue, Aug 2, 2016 at 4:47 PM, Utkarsh Sengar <utkarsh2012@gmail.com> wrote:
> Upgraded to spark2.0 and tried to load a model:
> LogisticRegressionModel model = LogisticRegressionModel.load(sc.sc(),
> "s3a://cruncher/c/models/lr/");
>
> Getting this error: Exception in thread "main"
> java.lang.IllegalArgumentException: Wrong FS: file://spark-warehouse,
> expected: file:///
> Full stacktrace:
> https://gist.githubusercontent.com/utkarsh2012/7c4c8e0f408e36a8fb6d9c9d3bd6b301/raw/2621ed3ceffb63d72ecdce169193dfabe4d41b40/spark2.0%2520LR%2520load
>
>
> This was working fine in Spark 1.5.1. I don't have "spark-warehouse"
> anywhere in my code, so its somehow defaulting to that.
>
> --
> Thanks,
> -Utkarsh

---------------------------------------------------------------------
To unsubscribe e-mail: user-unsubscribe@spark.apache.org


Mime
View raw message