spark-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kelum Perera <>
Subject spark-shell not starting ( in a Kali linux 2 OS)
Date Sun, 13 Nov 2016 04:50:26 GMT
Dear Users,

I'm a newbie, trying to get spark-shell using kali linux OS, but getting
error - "spark-shell: command not found"

I'm running on Kali Linux 2 (64bit)

I followed several tutorial including:

Scala (2.11.8), python (2.7), Java (1.8.0_111), spark (1.6.3) are available
in /usr/local/

I have amended the "bashrc" for the paths of above folders & sourced it.

export SCALA_HOME=/root/scala

export SCALA_HOME=/root/spark

When i run "echo $SCALA_HOME" it shows the path correctly.
but for "echo $SPARK_HOME" its a just empty line prints but no error pops &
courser moves to next line.

I tried keeping the files in "/usr/local/" folder too, but same result.
Also i tried with "pyspark", but the same result

Its great if someone can help me on this.

Thanks for your time & effort.

View raw message