spark-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chetan Khatri <chetan.opensou...@gmail.com>
Subject Re: Apache Hive with Spark Configuration
Date Wed, 04 Jan 2017 09:35:24 GMT
Ryan,

I agree that Hive 1.2.1 work reliably with Spark 2.x , but i went through
with current stable version of Hive which is 2.0.1 and I am working with
that. seems good but i want to make sure the which version of Hive is more
reliable with Spark 2.x and i think @Ryan you replied the same which is
hive 1.2.1 .

Thanks.



On Wed, Jan 4, 2017 at 2:02 AM, Ryan Blue <rblue@netflix.com> wrote:

> Chetan,
>
> Spark is currently using Hive 1.2.1 to interact with the Metastore. Using
> that version for Hive is going to be the most reliable, but the metastore
> API doesn't change very often and we've found (from having different
> versions as well) that older versions are mostly compatible. Some things
> fail occasionally, but we haven't had too many problems running different
> versions with the same metastore in practice.
>
> rb
>
> On Wed, Dec 28, 2016 at 4:22 AM, Chetan Khatri <
> chetan.opensource@gmail.com> wrote:
>
>> Hello Users / Developers,
>>
>> I am using Hive 2.0.1 with MySql as a Metastore, can you tell me which
>> version is more compatible with Spark 2.0.2 ?
>>
>> THanks
>>
>
>
>
> --
> Ryan Blue
> Software Engineer
> Netflix
>

Mime
View raw message