spark-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Druhin Goel <dru...@quantifind.com>
Subject [Debug] Upgrade from 1.4.1 to 2.0.0 breaks job
Date Wed, 02 Aug 2017 17:12:32 GMT
Hi,

I just upgraded our spark version from 1.4.1 to 2.0.0. Upon running a job
(which worked perfectly with 1.4.1) to test it, I see that it fails with an
assertion error:

"assertion failed: copyAndReset must return a zero value copy”. I saw a
thread related to this on StackOverflow, however, I could not find any code
or dependency in our codebase that implements the old Accumulator. We do
not use SparkRunner either.

What are some other reasons I would be seeing this error?

Thanks,
Druhin

Mime
View raw message