spot-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vivienne Pustell <...@yellingviv.com>
Subject Re: nfdump install instructions seem inaccurate
Date Mon, 02 Mar 2020 23:39:03 GMT
In the meantime, finally put in that PR to update the docs page to reflect
the need for a different version of automake while the longer term plan is
figured out.

I don't do a lot of wordsmithing docs type things, so if anyone feels up to
looking at this PR to make sure it's audience-friendly, that'd be great :)
https://github.com/apache/incubator-spot/pull/162

Cheers,
-Viv

On Wed, Feb 5, 2020 at 12:25 PM Tadd Wood <taddwood@apache.org> wrote:

> I support moving/forking the code in until we decide how we want to proceed
> with eliminating that dependency.
>
> Thank you,
> Tadd Wood
>
> On Wed, Feb 5, 2020 at 7:55 AM Jeremy Nelson <jeremy@digitalminion.com>
> wrote:
>
> > I agree with the sentiment that we should work towards eliminating the
> > dependency.
> > In the meantime, until we figure out how to do that, it may be necessary
> > for us to make changes to spot-nfdump.
> > I would suggest that just for our own sanity, we should include/fork the
> > project (open-network-insight/spot-nfdump) so we can make commits to it,
> > and so that unknown people can't make changes that might affect our
> users.
> > We could update the documentation to direct users to install our
> maintained
> > version, instead of the external copy.
> >
> > Jeremy
> >
> >
> > On Wed, Feb 5, 2020 at 12:08 AM Nate Smith <natedogs911@gmail.com>
> wrote:
> >
> > > I’ve not been active in this project for a while, so forgive me if this
> > > has already been addressed.
> > >
> > > I’m assuming this is for spot-nfdump?
> > >
> > > If so it’s worth saying unless someone has been maintaining it we
> should
> > > look at removing the dependency.
> > >
> > > Originally we cooked our own version due to time stamp issues. But this
> > > should really be handled post ingestion IMHO.
> > >
> > > - nathanael
> > >
> > > > On Feb 4, 2020, at 3:40 PM, skip cruse <f8al.err0r@gmail.com> wrote:
> > > >
> > > > I noticed when setting up nfdump for spot-ingest that there were
> some
> > > > errors around the version of automake that’s requried. Apparently
> > > automake
> > > > 1.14 is required and after installing that everything worked fine. I
> > did
> > > > some digging and it looks like this was already raised via SPOT-178:
> > > > https://issues.apache.org/jira/browse/SPOT-178. Perhaps someone
> could
> > > > update the website to reflect this dependency and add the additional
> > > setup
> > > > steps in there as well?
> > > >
> > > > Cheers,
> > > > Skip
> > > > --
> > > > if( bool halfWayThere == true);
> > > > printf "WOOOOOOOOOOOOOOOOAH! LIVIN ON A PRAYER";
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message