sqoop-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jarek Jarcec Cecho (JIRA)" <j...@apache.org>
Subject [jira] [Created] (SQOOP-2454) Drop JDK6 support
Date Fri, 31 Jul 2015 15:34:04 GMT
Jarek Jarcec Cecho created SQOOP-2454:
-----------------------------------------

             Summary: Drop JDK6 support
                 Key: SQOOP-2454
                 URL: https://issues.apache.org/jira/browse/SQOOP-2454
             Project: Sqoop
          Issue Type: Bug
    Affects Versions: 1.99.6, 1.4.6
            Reporter: Jarek Jarcec Cecho
            Assignee: Jarek Jarcec Cecho
             Fix For: 1.99.7, 1.4.7


[Following our mailing list discussion|http://markmail.org/thread/6jodptl3to2lsfsi]:

JDK6 has been officially put end of life by Oracle more then 2 years ago
(February 2013). Other projects in Hadoop ecosystems have already dropped JDK6 support - for
example Hadoop [1], HBase [2] or Pig[3] and hence I would like to kick off discussion to do
the same in Sqoop as well.

What exactly that would mean for our users:
* User would need to use at least JDK7 on the runtime - we’re spawning mapreduce job, so
entire cluster would have to be running on at least JDK7

What would that mean for Sqoop developers:
* We would change our build scripts to use -source and -target 1.7 [4] preventing the compilation
with JDK6
* We could use JDK7 specific language features in the source code [5]

Links:
1: http://markmail.org/thread/ytisa4w73ym4ee65
2: https://issues.apache.org/jira/browse/HBASE-11666
3: http://markmail.org/message/4pdyv22bimh5ae7n
4: http://docs.oracle.com/javase/7/docs/technotes/tools/windows/javac.html
5:
http://docs.oracle.com/javase/7/docs/technotes/guides/language/enhancements.html



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message