sqoop-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aravindakshan Srinivasan <s_arav...@yahoo.com>
Subject Re: Oozie + Sqoop + MySql UPSERT
Date Sun, 10 May 2015 05:42:46 GMT
This is now resolved. Turned out to be a Sqoop issue.
      From: Aravindakshan Srinivasan <s_aravind@yahoo.com>
 To: "user@sqoop.apache.org" <user@sqoop.apache.org> 
 Sent: Friday, May 8, 2015 9:00 PM
 Subject: Oozie + Sqoop + MySql UPSERT


I have an odd problem. I am trying to run an MySql upsert via Sqoop. It works fine from the
edge node that has Sqoop 1.4.5 installed. When I try to run via Oozie, I get this error.
org.apache.sqoop.tool.ExportTool - Error during export: Mixed update/insert is not supported
against the target database
This feature is available in the newer versions of Sqoop starting with Sqoop 1.4.3, which
is what my Oozie sharelib contains. Still, my first reaction was that the Sqoop jars in Oozie's
sharelib are different and hence throwing this error. As you know, the Sqoop via Oozie runs
on the Hadoop compute nodes. I tried copying the Sqoop jars from my edge node to the workflow/lib
dir. It still didn't work. 

Since then, I have tried everything I can think of, but can't get past this error. I have
even rebuilt the Oozie sharelib with Sqoop 1.4.5 and tried both  oozie.libpath and oozie.action.sharelib.for.sqoop
pointing to my rebuilt lib. Still no luck. What am I missing?
Thanks,Aravind --------------------------------------------------------------------------------------------Aravind


I have decided to stick with love. Hate is too great a burden to bear. - MLK, Jr.--------------------------------------------------------------------------------------------


View raw message