struts-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chakravarthy (JIRA)" <>
Subject [jira] Created: (STR-3203) AbstractMethodError: org/apache/struts/action/PlugIn.init(Lorg/apache/struts/action/ActionServlet;Lorg/apache/struts/config/ModuleConfig;)V
Date Thu, 01 Apr 2010 10:12:27 GMT
AbstractMethodError: org/apache/struts/action/PlugIn.init(Lorg/apache/struts/action/ActionServlet;Lorg/apache/struts/config/ModuleConfig;)V

                 Key: STR-3203
             Project: Struts 1
          Issue Type: Bug
    Affects Versions: 1.1.0
         Environment: In AIX environment the AbstractMethod Error is coming but when i tried
to deploy the Same EAR in Windoz Envin it s working fine 
            Reporter: Chakravarthy
            Priority: Blocker

Hi ,

Currently this isse persist in AIX Environment & we cannot able to proceed further it
is blocking the production .
This Issue cameup when we migrate the applpication from WAS 5.1 to 6.1
The applciation uses Struts.jar version 1.1 & we havnt changed any jars for the migration

While we test the applciation EAR in local Window WAS 6.1 sever all the jars loaded fine &
the applciation worked without any error.
Once we tried to deploy the same EAR in AIX environment(Client's WAS server),the
issue came up & blocked the production .
We have tried the following steps to resolve the error
     -Set the WAR Classloder Policy in WAS 6.1 to Single 
     -Created a Shared Library for Struts.jar explicitly
     - The Applciation Leve Class Loader Policy is of PARENT_FIRST

But the application failes due to this AbstractMethod Error Only in AIX environment.

Please suggest me a resolution to sovle this issue at the earliest 

My contact details : 973 -776-3120 Extension : 412378 

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message