subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ryan Schmidt <>
Subject Re: Help: svn: Working copy 'XXXX/XXXX/XXX' locked
Date Thu, 29 Jul 2010 23:31:53 GMT
On Jul 29, 2010, at 16:04, Di Hu wrote:

> I have some problems in using svn commands. I think this is because I have
> some file which have same names but in different cases(such as align.c and
> Align.c). 
> I tried to delete one of the files, and got:
> Hu-DimatoMacBook-Pro:reconstruction3d dhu$ svn delete
> /Users/dhu/reconstruction3D/Align.c 
> svn: Working copy '/Users/dhu/reconstruction3D' locked
> svn: run 'svn cleanup' to remove locks (type 'svn help cleanup' for details)
> I typed "svn cleanup" and tried again.  Then I got:
> Hu-DimatoMacBook-Pro:reconstruction3d dhu$ svn delete
> /Users/dhu/reconstruction3D/Align.c 
> svn: Use --force to override this restriction
> svn: '/Users/dhu/reconstruction3D/Align.c' is not under version control
> I also tried "mv" and "rm" , but both of them responded me "svn: 'Align.c'
> is not under version control".
> Can someone help me fix this problem? Thanks a lot!!

At the risk of repeating what you already know, it seems that Align.c is not under version
control. Does Subversion perhaps think it's called align.c instead? It would if, for example,
when you originally added it, you used "svn add align.c" instead of "svn add Align.c". If
that's the case, then use "svn rm align.c" to remove it, if that's what you want to do.

View raw message