subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rick Varney <>
Subject Problem setting up authz on svnserve
Date Fri, 05 Feb 2016 17:31:40 GMT

I am a newbie to using authz, and am trying to set it up for the first
time.  For reasons I don't understand, I can't seem to get it working.

I am using svnserve and fsfs, subversion 1.8.10 for both server and client
for testing.

My svnserve.conf setup is:

anon-access = none
password-db = passwd
authz-db = authz

Initial contents of my authz file (just trying to get *any* authz setup to
work at this point):

* = rw

With this setup, here is what my client says when I try to do an svn ls:

$ svn ls svn://my_repos

svn: E210002: Unable to connect to a repository at URL 'svn://my_repos'
svn: E210002: Network connection closed unexpectedly

I have tried giving an absolute path to authz, checking it into the
repository and giving a URL but the result is the same each time.  As soon
as I uncomment the authz-db line in svnserve.conf any access to the repo
results in the above error.  When I comment the authz-db line again, the
problem goes away.

The permissions, ownership, and location of my authz file match those of my
passwd file, and svnserve is accessing the passwd file ok.

Errors I see in my svnserve.log that *may* be related are:

28207 2016-02-03T18:31:50.113582Z - - ERR - 0 210002 Network
connection closed unexpectedly

28540 2016-02-03T18:50:55.871361Z - - ERR - 0 104 Can't read
from connection: Connection reset by peer

But these only occurred rarely, and not each time I tried to access the
repo and got the above client error.

At this point I'm stuck.  Am I doing anything obviously wrong?

Any suggestions on how I can debug this?

Many thanks!

Rick Varney

View raw message