subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Blaxton <blaxx...@yahoo.com>
Subject Re: autogen.sh produce wrong path to aclocal
Date Sun, 08 May 2016 12:09:52 GMT
Thank you,
That fixed the problem.
I tried placing /opt/freeware/bin in path before /bin directory:
export PATH=/opt/freeware/bin/:/opt/freeware/sbin/:$PATH
but I got other errors down the road and if you don't mind i explain it in the same mail thread.
After running autogen.sh, running ./canfigure thorws below error:checking for Expat... noconfigure:
error: Expat not found

If I pass apr and apr-util path to ./configure:
./configure --with-apr=/usr/local/apr --with-apr-util=/usr/local/aprutil
 configuration complete with no problembut I get error when I run make command:
grep: can't open /usr/local/apr/bin/lib/libapr-1.lased: Cannot find or open file /usr/local/apr/bin/lib/libapr-1.la.libtool:
link: `/usr/local/apr/bin/lib/libapr-1.la' is not a valid libtool archivemake: The error code
from the last command is 1.

Stop.

I am not sure what is going wrong in here and don't know how to fix it ?
I will start a new thread, so may be some one else has had the same issue.
Thanks      From: Branko Čibej <brane@apache.org>
 To: users@subversion.apache.org 
 Sent: Saturday, May 7, 2016 11:44 PM
 Subject: Re: autogen.sh produce wrong path to aclocal
   
On 08.05.2016 06:27, Blaxton wrote:
> autogen.sh is producing wrong path to aclocal:
>
> autogen.sh[83]: /bin/../share/aclocal:  not found
> /libtool.m4 not found (try setting the LIBTOOL_M4 environment variable)
>
> I have checked autogen.sh:
> below line determine location of libtoolize :
> libtoolize="`./build/PrintPath glibtoolize libtoolize glibtoolize1
> libtoolize15 libtoolize14`"
> which in my system is 
> /bin/libtoolize and it is symlinked to /opt/freeware/bin/libtoolize
>
> then  below line set ltpath to bin rather than /opt/freeware/bin
> ltpath="`dirname $libtoolize`"
>
> and below line:
> if [ -d "$ltpath/../share/aclocal/." ]; then
>        ltm4=`cd "$ltpath/../share/aclocal" && pwd`
>
> throws below error:
> autogen.sh[83]: /bin/../share/aclocal:  not found
> /libtool.m4 not found (try setting the LIBTOOL_M4 environment variable)
>
> how can I fix this ?
> Do I need to change the autogen or I can pass a variable to autogen.sh ?

Well, _did_ you try setting the LIBTOOL_M4 envrironment variable, like
the error message suggests?

Something like:

    env LIBTOOL_M4=/opt/freeware/share/aclocal ./autogen.sh

-- Brane



  
Mime
View raw message