On 3/8/2017 11:39 AM, David Aldrich wrote:

Hi

 

I am running svn 1.9.5 on Windows 10.

 

We run many repos under svn, and they have run fine for years.

 

In the last 24 hours one of our svn repositories has started exhibiting problems.  When I run ‘svn update’ against one of its branches the update does not complete, it hangs.

 

I have tried with other clients, the result is the same. I have to kill the update and run cleanup.  Other users see the same problem.

 

How can I identify the cause of this problem please?

 

Best regards

 

David

 

Can you open the Windows task manager while the update seems to be stuck and check the process information of the svn-update process? Can you determine whether CPU or disk-access is at 100% during the time? If not, is the process' CPU usage changing (between 0 and 0.1%) or is it completely stuck at 0%?

Do you have the option of checking the server load when this happens? I.e. if the server is running on Windows, check the task manager of the server-side svn process. Is that at 100% during the "stuck" update process?

Did you test whether a clean/fresh check out of the branch solves the problem?

-- 
Regards,
Stefan Hett