subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Shahaf <...@daniel.shahaf.name>
Subject Re: Svnadmin dump with include will lost the svn:log in sometime
Date Sat, 21 Mar 2020 17:03:54 GMT
钱海远(Nathan) wrote on Sat, 21 Mar 2020 06:08 +0000:
> I found the there is a BUG in subversion 1.10.6.
> 
> Svnadmin dump with include will lost the svn:log in sometime.
> 
> I was fix this issue several months ago , I forgot how to the issue happened again. But
I have a patch to fix this issue, the code was lost the processing for SVN_PROP_REVISION_LOG.
> 
> If there is no svn:log in the dump file , the load will be fail.

Let's take these issues one at a time.  The expected behaviour is:

1. 'svnadmin dump' should include all properties.

2. 'svnadmin load' should succeed even when svn:log is missing.

Now, to your patch.  First of all, the patch shouldn't affect svnadmin's
behaviour in any way, because svnadmin doesn't enter the codepath your
changed: that codepath is only used when authz is in effect, and
svnadmin never does authz.  (That's how #1 is implemented.)  Did you
perchance run 'svnrdump dump' instead?  That'd explain why your patch
had an effect.

Next, omitting svn:log in the svn_repos_revision_partial_access case is
not a bug; it's deliberately this way.

If you can reproduce a case in which either #1 or #2 don't hold, that
would be a bug.  However, given that your patch had an effect, you are
probably using some tool other than svnadmin.  So, please quote the
command lines you entered and the error messages they generated.

Mime
View raw message