tika-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From kevin slote <kslo...@gmail.com>
Subject Re: problem with embedded OLE attachments
Date Thu, 17 Oct 2013 13:53:03 GMT
I do.  But, when I deleted the jars from my classpath, I got the same error.
Additionally, is there a work around if I needed to have poi in my program?

On Thu, Oct 17, 2013 at 8:25 AM, Nick Burch <apache@gagravarr.org> wrote:

> On Thu, 17 Oct 2013, kevin slote wrote:
>> Hi, I was trying to parse a word file with an embedded OLE attachment and
>> I got this error...
>> Caused by: java.lang.IllegalAccessError: tried to access method
>> org.apache.poi.POIDocument.<**init>(Lorg/apache/poi/poifs/**
>> filesystem/DirectoryNode;)V
>> from class org.apache.tika.parser.**microsoft.WordExtractor
> Most likely you have mis-matched jars on your classpath. You need to
> ensure you have the same copy of POI that came with the version of Tika
> that you're using, and don't have any other ones. I suspect you either are
> using a different set of POI jars, or have two sets
> Nick

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message