tomcat-taglibs-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Taylor <christian.tay...@acadiau.ca>
Subject Re: jstl doesn't work
Date Sat, 22 Oct 2005 10:59:30 GMT
Hi Michael,

Did you include the necessary taglib directives at the beginning of your 
JSP? For example, to use the core taglib as you are doing:

<%@taglib prefix="c" uri="http://java.sun.com/jsp/jstl/core"%>

This needs to be included at the top of any JSP using the taglib. If you 
already know this, I apologize. It was the only thing I could think of 
that you didn't mention. Hope this helps.

 -Christian

michael Muttai wrote:

> Why do I get ${customers.firstName} when I use the following codes in 
> a jsp file?
>
> <c:forEach var="customers" items="${requestScope.customers}">
> <tr>
> <td><c:out value="${customers.firstName}"/></td>
> ...
> </tr>
> </c:forEach>
>
> I use JBoss 4.0.3. I include jstl.jar and standard.jar under 
> web-inf/lib and some *.tld files under web-inf.
>
> Any help is appreciated.
>
>
>
>
> Michael
>
> _________________________________________________________________
> On the road to retirement? Check out MSN Life Events for advice on how 
> to get there! http://lifeevents.msn.com/category.aspx?cid=Retirement
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: taglibs-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: taglibs-user-help@jakarta.apache.org
>

---------------------------------------------------------------------
To unsubscribe, e-mail: taglibs-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: taglibs-user-help@jakarta.apache.org


Mime
View raw message