tomee-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Han Hong Fang (JIRA)" <j...@apache.org>
Subject [jira] Created: (OPENEJB-1421) Mark some import packages as optinal in openejb-axis
Date Mon, 17 Jan 2011 08:21:43 GMT
Mark some import packages as optinal in openejb-axis
----------------------------------------------------

                 Key: OPENEJB-1421
                 URL: https://issues.apache.org/jira/browse/OPENEJB-1421
             Project: OpenEJB
          Issue Type: Improvement
    Affects Versions: 3.2
            Reporter: Han Hong Fang


 Hi all,

 I work on Apache geronimo project. when I add openejb-axis-3.2-SNAPSHOT.jar into geronimo
server 3.0-SNAPSHOT,  I notice that the MANIFEST.MF of openejb-axis imports these packages:

     org.apache.openejb.server.httpd;version="3.2",
     org.apache.openejb.server.webservices;version="3.2",
     org.apache.openejb.server.webservices.saaj;version="3.2",

 I found the above packages are in openejb-http-3.2-SNAPSHOT.jar and openejb-webservices-3.2-SNAPSHOT.jar,
but those packages are not used in geronimo server (they are not included in geronimo server
before geronimo adopting OSGi).

 I think making these three packages as "resolution:=optional" in MANIFEST.MF of openejb-axis
would solve above problem.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message