tomee-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fabian Schwarzer (JIRA)" <>
Subject [jira] [Commented] (TOMEE-1102) Remote adapter does transfer war to remote TomEE, but only path
Date Tue, 07 Jan 2014 18:55:51 GMT


Fabian Schwarzer commented on TOMEE-1102:


Repo and version for arquillian-tomee-remote:
and 1.6.1-SNAPSHOT

Arquillian test run starts on Windows 7 machine.

TomEE running in a VM that is hosted by the Windows 7 machine. The VM is Ubuntu Precise Vagrant
Box (which is 12.04 LTS)
In a second setup I left everything like above, except that I ran TomEE on the Windows 7 machine
and not inside the VM anymore...with the same error occuring.

> Remote adapter does transfer war to remote TomEE, but only path
> ---------------------------------------------------------------
>                 Key: TOMEE-1102
>                 URL:
>             Project: TomEE
>          Issue Type: Improvement
>          Components: TomEE Arquillian Adapters
>    Affects Versions: 1.6.0
>            Reporter: Fabian Schwarzer
>            Priority: Blocker
>         Attachments: TOMEE-1102.patch
> Previous discussion on the user mailing list:
> ------------------------------------------
> The TomEE remote adapter does not work in a setup where an already running remote TomEE
is not on the same system as the JVM that executes the Arquillian tests.
> The reason for this is that TomEEContainer#deploy (
does not deploy the archive but only passes the archives path to the remotly running TomEE.

This message was sent by Atlassian JIRA

View raw message