tomee-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fabio Jun Takada Chino (JIRA)" <>
Subject [jira] [Commented] (TOMEE-2223) Incorrect JPA entity used when running under docker
Date Sat, 18 Aug 2018 19:25:00 GMT


Fabio Jun Takada Chino commented on TOMEE-2223:

After more tests, I discovered that the issue is, in fact, intermittent with a high chance
to happen without debug mode, lower chances to manifest when the debug mode is enabled and
almost no chance to happen when the debugger is attached before the first execution of the

It is also important to notice that, if the issue does not happen in the first time the code
is executed after the startup of TomEE, it remains bug free for the entire life of the server.
On the other hand, if the issue manifests itself in the first run, it will remain this way
until the server is restarted again.

I tried to reproduce the issue outside the docker container but I was unable to get this result.
The same behavior can be found on at least two distinct machines, with 2 completely different
hardware setup (one is an i7-6700K with 32GB of RAM and the other is a Dual Xeon E5620 with
64GB of ECC RAM), both running Ubuntu 18.04 (desktop for one and server for the other).

Thanks in advance,

> Incorrect JPA entity used when running under docker
> ---------------------------------------------------
>                 Key: TOMEE-2223
>                 URL:
>             Project: TomEE
>          Issue Type: Bug
>          Components: TomEE Core Server
>    Affects Versions: 7.0.5
>         Environment: * Docker version 17.12.1-ce, build 7390fc6;
> * Official Ubuntu 18.04 (x64) docker image with OpenJDK 8 installed;
> * apache-tomee-webprofile-7.0.5;
> * Apache Derby (embedded);
>            Reporter: Fabio Jun Takada Chino
>            Priority: Minor
> While packing a very simple web application inside a docker container based on the official
Ubuntu 18.04 image, I found a very inconvenient error related to OpenJPA using the wrong entity
to access the database.
> When it happens, the following exception can be found in the log:
> {{org.apache.openjpa.persistence.ArgumentException : The given value "test" cannot be
converted into an identity for "class EntityB".  The value is the wrong type (java.lang.String)}}{{
using the wrong entity to store information inside}}
> The major problem with this code is that the actual method is trying to access the entity
EntityA instead of EntityB. The conversion error occurs because the ID for EntityB is a composite
value while the ID for EntityA is indeed a string.
> Given that, I tried to trace the issue using a remote debugger but, when I activate,
the problem vanishes. It does not matter if the debugger is connected or not. Since it is
not a critical application, I can workaround it by leaving the remote debugger enabled but
it would be a real issue for production environment.
> The docker image I'm using as the base can be found in the Docker Hub with the name opencs/ubuntu-openjdk-8-headless.
> The application is a single WAR file with some EJBs, JPA entities, a few servlets and
a few JSF pages. Almost all JPA entities have single primary keys but one of them have a composite
key with 2 strings.
> Thanks in advance,

This message was sent by Atlassian JIRA

View raw message