tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Blevins <david.blev...@visi.com>
Subject Re: NullPointerException inside IvmContext.lookup
Date Fri, 23 Feb 2007 02:35:00 GMT
Hi Kenan, looks like your email got overlooked.  Very sorry.  Hope we  
can still help you if you need it.  See below...

On Feb 8, 2007, at 4:30 PM, Kenan Sevindik wrote:

> I have developed a test web application with a session bean  
> deployed on
> tomcat. The code and configuration is the same as Hello example.  
> However,
> when i try to run web app, I got following exception:
>
> java.lang.NullPointerException
> at org.openejb.core.ivm.naming.IvmContext.lookup(IvmContext.java:152)
> at javax.naming.InitialContext.lookup(InitialContext.java:351)
> at org.apache.jsp.test_jsp._jspService(test_jsp.java:52)
> at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:94)
>
> I have already checked open-ejb logs, and my tomcat configuration  
> twice.
> There isn't any problem over there. I have found same problem in  
> the net
> after a quick googling:
> http://www.mail-archive.com/openejb-users@incubator.apache.org/ 
> msg00053.html
> As it was mentioned above there seems no obvious reason for this  
> error to
> occur.

It seems to get that error an null value has to actually be in the  
jndi namespace.  This shouldn't happen ever, but I'll definitely name  
sure we check for that in the 3x codebase.

Can you paste the section of the openejb.log where we list the beans  
deployed and also the chunk of code you are using to lookup your ejb?

-David


Mime
View raw message