tomee-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Raul Lapeira Herrero" <r...@roboticspot.com>
Subject Re: Incompatibility between openejb 3.0 and hibernate 3.2.6a
Date Thu, 31 Jul 2008 07:04:22 GMT
Well, maybe this is even further away from the group intention, but just wanted to add to Chris
comment that trying to integrate spring with any 'spring plugin' provided by other API usually
gives a lot of version compatibility problems, we suffered that in a couple of proyects.

Regards.
------Mensaje original------
De: Christian Schuhegger
Para: users@openejb.apache.org
Responder a: users@openejb.apache.org
Enviado: 31 Jul 2008 08:51
Asunto: Incompatibility between openejb 3.0 and hibernate 3.2.6a

Hello,

this is not really related to openejb directly, but I thought it might 
help other users that use openejb.

I tried to use openejb 3.0 together with hibernate 3.2.6ga in a maven 
project. The transitive dependencies of openejb and hibernate collide on 
asm.jar. A similar problem is described here:
http://blog.springsource.com/main/2007/06/11/asm-version-incompatibilities-using-spring-autowired-with-hibernate/
or here:
http://forum.springframework.org/showthread.php?t=26713&highlight=cglib-nodep+hibernate
http://jira.springframework.org/browse/SPR-3856

The solution is to exclude the dependency on asm and cglib on hibernate 
and to add a dependency on cglib-nodep.

Just fyi,
-- 
Christian Schuhegger
http://www.el-chef.de/


Mensaje enviado desde una BlackBerry, disculpe la brevedad del email.
Mime
View raw message